Hi Elizabeth,

Thanks for joining Swapdom.

I see your account is in good order.  What you are experiencing is probably a browser issue. Usually you can get around it in one of the following ways:
1) Close and re-open your browser.
2) Clear the browser's cache
3) If the above do not help, use a different browser.  We support current versions of Firefox, Chrome, Safari, IE and Opera.

I would appreciate it if you gave me your browser version.

Let me know if this helps.
I am using Chrome. I cleared my cache for the past 4 weeks (farther back than I've ever been to the Swapdom site) and it is still not working. After I enter my password and click on login you can briefly see what looks like profile heads icon in the upper right hand corner, then it goes back to the home screen.
The momentary appearance of the profile head in the upper right suggests we are past any cookie issues and are facing probably privacy protection issues.
Are you in private browsing mode?  Swapdom uses features to let you share your Swapdom-profile with friends and some privacy settings in the browser may be denying that.  We use the addthis service to allow you to do this, and the browser may be blocking it.

Is it easy for you to try a different browser, or to disengage private browsing for a moment?

Hi Elizabeth,

We made some changes on our side in an effort to alleviate the post-login problem you are facing.
Would you like to give it another try?

I am experiencing the very same issue. It is not the fault of the browser, as I have tried with IE, Firefox, Chrome, Safari, and Comodo Dragon.
All software and browsers are up to date, cache is cleared, cookies are
accepted, site and account have been verified, not in private browsing
mode. ;)

Thanks for the input you gave.
I have disabled the social add-ons for your account, as I suspect that it is these that cause the problem.  Would you be kind enough to try again please?

I agree with you that it is not the browsers.  I see the attempts and I see the session cookies being accepted.  And from the way you report,  I trust that you handle cache, private browsing and update issues fine.  Really strange as we have users operating with these browsers. 

If you still have the patience to pursue this, can you try from another computer when you have the chance?   I would love to get to the bottom of this.

*haha* Was it that obvious that I work in the IT field? ;)

I just tried it and it works perfectly! Thank you so very much. <3
Thanks Jennifer,
It is hard to hide it!
One last question if you please, because I asked you to try two things and it is important for us to know which one worked. 
Can you now work the site from your original computer where you encountered the problem?

Oh, yes! My apologies - that will teach me to drink all the coffee before answering email.

I originally reported the issue while using my work computer, but the very same was occurring on my home computer as well (which has almost the same specs and all the same browsers). I am assuming that since the social add-ons are account-based, the issue will have resolved itself at work as well. I will be sure to clear cache, etc. before attempting to use Swapdom again from work, but can report back here if the issue continues to occur, I assume. :)
Many thanks Jennifer.  I will eagerly await your news about the original machine to nail this one.
I am adding one free shipping coupon to your account, as a small token of thanks for your contribution to our effort.

Merci! Greatly appreciated. Let me know if I can be of anymore help in testing. I may be a geek, but a well-dressed one at that.
Sorry it has taken me so long to respond. I was able to successfully log on from my home computer. I also use Chrome at home. At the office today and was unable to log in. It's not too big of a problem because the main amount of time I will spend on the site will be from my home computer. Thanks for your help on this.
No problem and thanks for getting back to me.